Issue
You are getting an "incorrect password" error when logging in to your Smarter Call Center (SCC) email account (@smartercallcenter.net).
Cause
Below are the possible causes of getting an "invalid password" error when logging in to your SCC.net mailbox:
- The password entered is wrong
- Password has expired
| Note: For security and compliance purposes, we enforce a 90-day password expiry policy. Notifications to change your password are sent 7, 5, 3, and 1 day(s) before the password expiry date. |
Resolution
Password entered is wrong
- Passwords are case-sensitive. Make sure the correct capitalization is used.
- Ensure that the password entered is spelled correctly
- Verify that the caps lock key is not enabled.
Password has expired
You need to change your password for your SCC.net email account. To do this, follow the steps below:
- Log in to the SCC email dashboard at https://mail.smartercallcenter.net and enter your current password.
- To update the password, follow the steps described in the article Changing Your SCC.net Email Password.
- Once the password has been changed, access the mailbox at https://mail.smartercallcenter.net/sogo using the new password.
Please refer to the article Managing Your SCC.net Email Password Expiry Notifications for further details on keeping your accounts secure and always accessible.
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